Stytch - Stytch Dashboard is down – Incident details

Stytch Dashboard is down

Resolved
Major outage
Started 22 days agoLasted 22 minutes

Affected

Website

Major outage from 11:38 PM to 12:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.